WikiTurk
Editor Login | Register
Ekle

> Bilgisayar > Networking

Huzur-uKalb
(Date : 28.11.2016 16:13:24)


Cisco Vlan Konfigirasyon Ayarları


 Reklam



Vlan Nedir ?
Sanal yerel alan ağı (VLAN), bir yerel alan ağı (LAN) üzerindeki ağ kullanıcılarının ve kaynakların mantıksal olarak gruplandırılması ve switch üzerinde port’lara atanmasıyla yapılır. VLAN kullanılmasıyla her VLAN sadece kendi broadcast’ini alacağından, broadcast trafiği azaltılarak bant genişliği artırılmış olur.


Ağ Topolojimizi yapılandırmak ve planlamak için oluşturdum.
Topolojiyi açık olarak veriyorum ki daha önceki konularımda sadece komutları vermiştim.
Buradan hem kendiniz öğrenirken aynı topolojileri oluşturarak birebir veya kendiniz değiştirerek komutları daha iyi kavrayarak yapabilirsiniz.

Vlan Oluşturma
Switch 1 üzerinden ilerleyeceğiz.

Switch komut satırını üstüne tıklayarak CLI sekmesinden ulaşabiliriz.

İlk olarak Vlan oluşturuyoruz. Bunun için;
Switch1(config)# vlan 10
switch1(config-vlan)# name Cyber-Warrior
Switch1(config)#exit
Switch1(config)# vlan 20
switch1(config-vlan)# name Cyber-Warrior.org
switch1(config-vlan)# exit
switch1(config)#

Ben burada 2 adet oluşturarak vlan -20- Yazarak vlan id değerini 10 ve 20 olarak 2 tane belirledim. Bunu siz 1 de yapabilirsiniz 100’de size kalmış.

Vlan Port Atama
Gelelim bağlı olan bilgisayarları oluşturduğumuz vlan’lara atamaya.
Atamak istediğimiz pc’nin bağlı olan portuna giriyoruz.

Switch1(config)# interface fastEthernet 0/1
Switch1(config-if)# switchport mode access
Switch1(config-if)#switchport access vlan 10
Switch1(config-if)#exit

Switch1(config)#interface fastEthernet 0/2
Switch1(config-if)#switchport mode access
Switch1(config-if)#switchport access vlan 20
Switch1(config-if)#exit

Switchport mode access: Bu portta bilgisayar bağlı olduğunu gösteriyoruz.
switchport access vlan -numara- : Porta atamasını yapacağımız vlan bilgimizi giriyoruz.
Vlan atamalarımız gerçekleşti.

Vlan Bilgilerini Izleme
Vlan bilgilerini switch üzerinde görmek için ayrıcalıklı kip’den show vlan yazarak görüntüleyebiliriz.



switch# show vlan : vlanlar hakkında bilgi verir.

Vlan Router Yapılandırma

Switch1(config)# interface fastEthernet 0/24 : Routerin veya switchlerin bağlı olduğu porta girerek
Switch1(config-if)# switchport mode trunk : Komutunu girerek diğer vlanlar ile haberleşmesini sağlıyoruz. Aksi halde farklı vlan’lar yani 10 ile 20 vlan’ı haberleşmez.
Not: Switch üzerinde bağlı olan diğer switch portlarına yazmamız gerekiyor.
Vlan Router Alt Interface Oluşturma

Şimdi Router’imiz üzerinden vlan port havuzunu ayarlıyacağız.
Farklı vlan’ların haberleşmesini sağlayacak.

Router(config)# interface fastEthernet 0/0 : Switch’in bağlu olduğu porta giriyoruz.
Router(config-if)# no ip address : ip adresi ataması yapmıyoruz boş kalması kafi.
Router(config-if)# no shutdown : portu yeniden başlatıyoruz.
Router(config-if)# exit

Router(config)# interface fastEthernet 0/0.10 : Oluşturduğumuz vlanler için alt interface oluşturur. Oluşturduğumuz vlan bu interfaceden haberleşir. Dikket edelim. 0/0.10 yazdım çünkü oluşturduğumuz vlan 10 du.
Router(config-subif)# encapsulation dot1Q 10 alt interface’ye vlan bilgisini eklemek için IEEE802.1Q ‘e ait protokolün vlan 10 da olduğunu gösterir.
Bunu yapmazsak paketler iletilmez !
Router(config-subif)# ip address 192.168.3.1 255.255.255.0 : vlan 10 için alt interface için ip adresi girer. Vlan 10’da bulunan pc’ler 192.168.3.0 varsayılan ağ geçidini ve alt ağ maskesini kullandığını belirtiriz.
Not: 192’li ip C sınıfı bir ip’dir. Alt ağ maskesi 255.255.255.0 olur.

Vlan 20 için alt interface oluşturup gerekli atamaları aynı şekilde yapıyoruz. Fakat ip ve dot1Q protokolüne burada dikkat edelim.
Router(config)# interface fastEthernet 0/0.20
Router(config-subif)# encapsulation dot1Q 20
Router(config-subif)# ip address 192.168.2.1 255.255.255.0
Router(config-subif)# end













Derecelendir
Kaynak http://www.cyber-warrior.org/Forum/cisco-vlan-konfigirasyon-ayarlari_593660,0.cwx
İçerik İhbarı



Open Source Document Project AUP&TOS